Смотрим IPTV через Mikrotik

Подключение IPTV приставки к маршрутизатору Mikrotik (hex lite, hap lite и др.)

Устанавливаем пакет multicast

Для установки дополнительных пакетов загружаем с официального сайта Extra-package для нужной архитектуры.
Например для популярных моделей:
hEX lite это будет MIPSBE, для
hAP lite — SMIPS (до недавнего времени для данного устройства не было этого пакета, но по просьбам трудящихся добавили).

Из архива, берем пакет multicast и помещаем его в раздел файлы (files).

Для текущей прошивки 6.35.2, актуальны следующие пакеты:


multicast-6.35.2-mipsbe.npk
multicast-6.35.2-smips.npk

Перезагружаем роутер (/system reboot).

Настройка IGMP Proxy

После перезагрузки в разделе Routing появится раздел IGMP Proxy.

Настройка.

Routing -> IGMP Proxy

Жмем Add new:

Пишем данные:

Interface — ether1
Alternative Subnets — 0.0.0.0/0
Upstream — cтавим галочку

Жмем Add new еще раз:

Выбираем нужный интерфейс.

Interface — bridge1

(IPTV приставку можно подключить к любому порту входящему в данный мост)


/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
add interface=bridge1

Firewall

Если используется firewall, добавляем правила, не забываем что они должны быть выше блокирующих.

Chain – input
Protocol — igmp
Action – accept

Chain – input
Protocol — udp
Dst-Port — 1234
Action – accept


/ip firewall filter
add chain=input protocol=igmp
add chain=input dst-port=1234 protocol=udp

update 16.08.2017

В такой конфигурации мультикаст будет лететь во все порты, в том числе и wifi, что заметно скажется на скорости подключения.
Для предотвращения этого момента нужно сделать следующее:

Выбираем беспроводной интерфейс, расширенные настройки, далее переводим Multicast helper в full.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *