Mikrotik скрипты, работа с логами

Данная заметка касается применения скриптов для своевременного оповещения об аварии.
Скрипт должен записать сообщение в основной лог микротика и отправить сообщение на почту.

Используется:

/system scripts
/system scheduler

1
2
3
4
:if ([/interface eoip get [find name="EoIP_my_001"] running]=false) do={
/log warning ("EoIP down")
/tool e-mail send to="xxxx@xxxx.xxx" from="yyyy@yyyy.yy>" server="10.10.10.10" subject="Host is down."
}

server=10.10.10.10 — в данном случае означает сервер через который пересылается почта.

Скрипт запускает через встроенный Scheduler с нужным интервалов времени.
Вместо оповещения, можно сделать конкретное действие, добавить else для обработки если true, вопрос фантазии.

1
/system scheduler add name=schedule3 on-event=script_name_for_run interval=00:03:00 policy=read,write

P.S. Изменить кол-во сообщение в логе и очистить предыдущие можно таким образом:

1
2
/system logging action set disk-lines-per-file=1
/system logging action set disk-lines-per-file=100

Первая строчка устанавливаем размер лога в 1 запись, тем самым удаляет все что было до этого, вторая соответственно выставляет длину лога в 100 записей.

Mikrotik скрипты, работа с логами: 3 комментария

  1. Иван

    Скрипты могучая вещь, да и вообще микроты молодцы.
    Сейчас интересуюсь как сделать так чтобы канал распределялся динамически, т.е. имеем 10 мбит., нугрузки нет, отдаем всем ровно, появилось много клиентов, делим так чтобы никто не мог на себя забрать все и скажем оставался какой-нибудь резерв.

  2. admin Автор записи

    Не знаю, может быть в другой версии работало, но перестало, сейчас верно так:

    /system logging action set memory memory-lines=1
    /system logging action set memory memory-lines=100

  3. Sancho

    Не понятно, почему нельзя очистить логи. Может быть не туда смотрю?
    Нужно не забывать про SNTP, чтобы потом в этих логах разобраться.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Лимит времени истёк. Пожалуйста, перезагрузите CAPTCHA.